SolidWorks >> Arkusze blachy >> Skala pojemności zbiornika
Autor Wypowiedź
SW 2018 SP5
2020-08-29, 20:38
Pomógł 0 raz(y).
Próbuję zrobić skalę pokazującą ilość cieczy w zbiorniku przy pomocy arkusza blachy. Chodzi mi o to aby można było zamodelować ją i "przykleić" na zbiornik a jednocześnie rozłożyć ją aby wykonać z niej rysunek.
Ładnie udaje mi się zawinąć skalę wokół kawałka rury (zbiornik będzie z rury)

jednak przy próbie rozłożenia albo pojawiają się błędy (wersja pierwsza) albo rozwinięcie jest bez skali.


Co robię źle albo w jaki inny sposób uzyskać efekt, na którym mi zależy?

Plik wersja 1:
https://www.pswug.info/image/forum/forum_760_8_3254_10343.sldprt

Plik wersja 2:
https://www.pswug.info/image/forum/forum_760_8_3254_10344.sldprt
 
CSWP, CSWE, CSWI *** solid-blog.pl ***
2020-08-29, 22:36
Pomógł 384 raz(y).
A po co robić to zawijaniem (wrap)? Skoro blacha jest rozłożona, to wówczas wytnij na płasko i zagnij ponownie.
Z pewnością nie rozwija bo chodzi o cięcie prostopadłe.

Nie będę się czepiał, ale jaki jest sens rysować zbiornik/blachę za pomocą pogrubionej powierzchni? Przecież to się robi jedną operacją wyciągając blachę z łuku.

ps. z tymi obrazkami coś się popsuło, zgłosiłem to już koledze, który obiecał spojrzeć po weekendzie.
 
SW 2018 SP5
2020-08-30, 18:42
Pomógł 0 raz(y).
    Kęska Paweł

    Nie będę się czepiał, ale jaki jest sens rysować zbiornik/blachę za pomocą pogrubionej
    powierzchni? Przecież to się robi jedną operacją wyciągając blachę z łuku.

Pierwsza wersja została tak zrobiona jak wyżej.
Druga jako alternatywa powstała przez pogrubienie powierzchni i zamianę na blachę.

Nadal mi to nie wychodzi.
Tworzę blachę z łuku, rozkładam ją, na niej szkic i wycinam.
Przy zawijaniu pojawiają się błędy i brak napisów.
Jeżeli przy wycinaniu zaznaczę opcję "przez wszystko" to po zawinięciu jest prawie dobrze ale tworzą się nowe obiekty ze środków zer, które nie są zawijane.

Do tego plik:
https://www.pswug.info/image/forum/forum_760_8_3254_10347.sldprt
 
CSWP, CSWE, CSWI *** solid-blog.pl ***
2020-08-30, 22:10
Pomógł 384 raz(y).
Może literki typu O nie mają mostków... to się objawia brakiem możliwości rozłożenia. Jutro mogę spojrzeć na plik SW.
 
SW 2018 SP5
2020-08-31, 19:27
Pomógł 0 raz(y).
Zgadza się, nie mają.
Co wtedy?
Pozostaje rozbijanie tekstu do elementów graficznych i ręczna przeróbka?
Makabra ...
 
CSWP, CSWE, CSWI *** solid-blog.pl ***
2020-08-31, 22:39
Pomógł 384 raz(y).
Można ręcznie dorysować wspomniane mostki. Są podobno też czcionki specjalne dla blach. Trzecia opcja z jaką się spotkałem to umieszczanie tekstu na rozwinięciu w DXF. Ale to nie zmienia faktu, ze jeżeli "o" będzie wyglądało jako "0", to po wypaleniu środek wypadnie...
 
wsparcie tech, audyty, szkolenia
2020-09-01, 22:29
Pomógł 8 raz(y).
Cześć Dariusz,

popieram w 100% Pawła.
Niestety czeka Cię ręczne rysowanie mostków po wcześniejszym rozbiciu tekstu, lub zastosowanie odpowiedniej czcionki:

Zapoznaj się z tym wątkami:
https://forum.solidworks.com/thread/187069
https://forum.solidworks.com/thread/59332

Pozdrawiam,
Kajetan Sekuła
 
SW 2018 SP5
2020-09-02, 20:37
Pomógł 0 raz(y).
Znalazłem czcionkę z mostkami:
https://www.pswug.info/image/forum/forum_760_8_3254_10361.zip
Aby ją zainstalować wystarczy pod prawym przyciskiem myszy nacisnąć "Zainstaluj".

Po zastosowaniu tej czcionki jest lepiej w przypadku, gdy blachę tworzę z pogrubionej powierzchni, a następnie zawijam na niej szkic z napisami.
Efekt jest bardzo dobry.
Jednak po rozwinięciu blachy cały szkic wycina blachę na wylot, nawet jeśli przy zawijaniu zaznaczę opcje nawijania z dodawaniem materiału.

https://www.pswug.info/image/forum/forum_760_8_3254_10362.zip

Jeżeli natomiast tworzę blachę bezpośrednio z łuku, rozwijam ją, na jej powierzchni wycinam szkicem na pewną głębokość to po ponownym zawinięciu są błędy i nie ma wycięć na zawiniętej blasze.

https://www.pswug.info/image/forum/forum_760_8_3254_10363.zip

EDIT 2020-09-11:

Podpiąłem jeszcze raz pliki już jako pliki *.zip.
Poprzednio mogłem pobierać pliki SW bezpośrednio.
Teraz się nie da, więc jeszcze raz jako pliki spakowane.
 
CSWP, CSWE, CSWI *** solid-blog.pl ***
2020-09-13, 21:06
Pomógł 384 raz(y).
Jak ma to ostatecznie wyglądać? Otwór tych oznaczeń ma być przelotowy czy na pewną głębokość?
Pobrałem plik probe3 - nie widzę tam mostków.

Jak jest zrobiony tekst poprawnie to wszystko działa jak należy.
 
SW 2018 SP5
2020-09-14, 20:29
Pomógł 0 raz(y).
Co do plików, ma Pan rację.
Nie miałem już tamtych starych i zapisałem inne, które nie miały mostków.
W poprzednim poście zaktualizowałem pliki i czcionki są z mostkami.

Zachowują się tak jak opisałem w poprzednim poście.

Plik pierwszy powstały przez pogrubienie powierzchni, zamianę w blachę, nawinięcie szkicu na pewną głębokość w nawiniętym stanie wygląda tak jak powinien.
Po rozwinięciu blachy jest dobrze, poza tym, że nie wiedzieć czemu w stanie rozwiniętym wycina "na wylot", a tak nie powinno być. W stanie nawiniętym napis wycięty jest tylko na zadaną głębokość.
W stanie zwiniętym:

W stanie rozwiniętym:

Jeżeli natomiast tworzę blachę bezpośrednio z łuku, rozwijam ją, na jej powierzchni wycinam szkicem na pewną głębokość to po ponownym zawinięciu są błędy i nie ma wycięć na zawiniętej blasze. Chciałbym aby po zwinięciu na blasze był napis na głębokość zadaną przy wycinaniu w stanie rozwiniętym.
W stanie rozwiniętym:

W stanie zwiniętym (błędy):


Przy okazji: u mnie nie są widoczne obrazki na forum. Czy to tylko mój problem?
Edit 15.09.2020:
Teraz już pięknie widać obrazki na forum. Dziękuję.
 
CSWP, CSWE, CSWI *** solid-blog.pl ***
2020-09-15, 23:01
Pomógł 384 raz(y).
Trzeba wyciąć na wylot i po sprawie. W sumie co za różnica (poza tym, że się medium "wyleje"), na rozwinięciu widać krawędzie a nie głębokość cięcia.

Albo trzeba skleić dwie blachy i będzie się rozwijał i będzie nieprzelotowo. Widocznie na zgięciu nie można wycinać na pewną głębokość - ale to już do dystrybutora uwaga.

Ja mam tak, że jeżeli czegoś się nie da zrobić to nie drążę przez kilka dni tylko szukam rozwiązania zastępczego. Ale jednocześnie rozróżniłbym błędy w programie od ograniczeń w funkcjonalności.
 
SW 2018 SP5
2020-09-16, 18:06
Pomógł 0 raz(y).
Drążę temat przez kilka dni bo chcę dowiedzieć się jak go rozwiązać bo zwyczajnie mogę czegoś nie wiedzieć. Może robię jakiś błąd?
Ostatecznie, jeśli czegoś nie da się w tym programie zrobić to nie zamierzam dalej się z tematem kopać ale zadowalam się obejściem problemu.
Ale żeby się tym zadowolić, chcę się upewnić, że danego problemu nie da się rozwiązać wprost.
Dziękuję wszystkim za zainteresowanie problemem.
 

PSWUG

Strefa Resellera

Publikuj

Społeczność

Ankieta

Linki

RSS

BOT