SolidWorks >> Powierzchnie >> Błędy po łączeniu powierzchni
Autor Wypowiedź
2017-11-23, 14:52
Pomógł 1 raz(y).
Dzień dobry,

Po wykonaniu "Połącz powierzchnie" powstają na połączonej powierzchni wady, których nie mogę usunąć. Poniżej rysunki "przed" i "po". Jaka może być tego przyczyna, gdzie szukać w drzewie operacji szukać rozwiązania?





Pozdrawiam

 
CSWP, CSWE, CSWI *** solid-blog.pl ***
2017-11-23, 17:56
Pomógł 394 raz(y).
Czasem tak jest, że powierzchnie zbiegają się do jednego narożnika, częściej to obserwuję w plikach importowanych. Wynika to z tolerancji dopasowania - bez modelu nie da się określić, co jest przyczyną. Czy podczas łączenia włączona jest kontrola przerw?

Naprawiałbym to poprzez wycięcie problematycznego fragmentu a następnie odtworzył na nowo. Można bazować na odsuniętej wcześniej powierzchni. Czasem pomaga dodanie dodatkowej granicy poza problematycznym wierzchołkiem, po połączeniu można ją usunąć jako usuń ścianę.
 
2017-11-24, 12:42
Pomógł 1 raz(y).
Podczas łączenia włączona jest kontrola przerw.
Wygląda na to, że pomysł z kopiowaniem i odtwarzaniem powierzchni się sprawdza, dziękuję. Aczkolwiek po teoretycznym naprawieniu problematycznych fragmentów nadal mam problem z połączeniem powierzchni rdzenia z powierzchnią podziałową, wyskakuje komunikat o samoprzecinającej się powierzchni.
Na razie obejrzałem wszystko na szybko idąc po linii neutralnej i nie zauważyłem nakładających się powierzchni.
Czy jest jakiś trik pozwalający wykryć takie kłopotliwe miejsce?
 
CSWP, CSWE, CSWI *** solid-blog.pl ***
2017-11-24, 13:08
Pomógł 394 raz(y).
Na karcie Oceń > Sprawdź lub trzeba zapisać w parasolidzie i po otwarciu uruchomić diagnostykę importu. To pozwoli znaleźć problemy (ewentualnie je naprawić) ale nie usuwa przyczyny.
 
2017-11-24, 14:41
Pomógł 1 raz(y).
Eksportowałem obie powierzchnie (rdzenia + podziałową) do Parasolida. Diagnostyka nie wykazała błędów, a powierzchnie połączyły się bez problemu. Udało się ostatecznie stworzyć bryłę rdzenia.
Niestety problem rozwiązany jest jedynie połowicznie, bo nadal nie wiem w którym miejscu powierzchnie zachodziły na siebie, program tego nie pokazuje. No i dlaczego te same powierzchnie w pliku części nie chcą się połączyć, a po eksporcie do Parasolida już tak? W przypadku gdy będę chciał zmodyfikować podział wypraski trzeba będzie za każdym razem eksportować do Parasolida. Robota za każdym razem od nowa, chyba że będę bawić się modelowanie fragmentów stempla. Nieciekawie. :(

Edit: udało się rozwiązać problem inaczej - przy łączeniu powierzchni odznaczyłem Kontrolę przerw i poszło.
 

PSWUG

Strefa Resellera

Publikuj

Społeczność

Ankieta

Linki

RSS

BOT