SolidWorks >> Makra >> Zapis makra jako .vbproj
Autor Wypowiedź
SOLIDWORKS 2018
2017-04-24, 19:50
Pomógł 43 raz(y).
hej,

Jak to możliwe, że na tych samych wersjach SW przy tworzeniu makra mogę je zapisać na jednej wersji SW tylko jako .swp a na drugiej mam do wyboru oprócz .swp jeszcze .vbproj i .csproj ? Doinstalowalem api sdk ale nie pomogło.
 
.
2017-10-05, 06:30
Pomógł 48 raz(y).
Witam,
Dołączam się do tematu. Po przejściu na Win10 we wszystkich SW 2015 SP 5 w firmie nie ma możliwości uruchomienia ani edycji makr VSTA (.dll), jest tylko .SWB i .SWP.
Zainstalowanie API SDK też nie pomogło.

PS
Zainstalowałem na próbę SW2016 i jest ok.
Na necie wyczytałem informację MS ( https://forum.solidworks.com/thread/99114 ), że SW2015 SP5.0 ma normalnie działać w Win10, Ściema :(
 
.
2017-10-25, 13:17
Pomógł 48 raz(y).
Niestety poprawka. Pod SW 2016 i 2010 też nie chodzi. Poprzednio napisałem , że jest ok. ale to była zmyłka. Pokazywał się wybór vbproj i csproj ale się nie uruchamiało a później znikał też wybór vbproj i csproj i zostawał jedynie swp. Po przeładowaniu SW sytuacja się powtarza.
 
SOLIDWORKS 2018
2017-10-26, 07:05
Pomógł 43 raz(y).
W SW 2018 też tylko *.swp
 
.
2017-10-26, 13:37
Pomógł 48 raz(y).
Oto fragment odpowiedzi od eksperta SolidWorks:
. . .
Proszę też sprawdzić czy zainstalowany jest .NET framework 3.5?
Kolejna rzecz, przy instalacji SOLIDWORKS trzeba zainstalować/zaznaczyć „Visual Studio Tools”. Tego niestety nie da się doinstalować (modyfikuj instalacje) tylko trzeba odinstalować SOLIDWORKS i zainstalować ponownie (przy pierwszej instalacji jest możliwość wybory tego narzędzia).
. . .

Sprawdziłem i niestety VisualStudio 2015 nie mam zainstalowanego. :(
"Trochę" mnie to wkurzyło, bo ta opcja moim zdaniem przy instalacji powinna być domyślnie włączona. Solida instalował nasz informatyk i on nie miał o tym pojęcia.
To jest chyba specyfika Win 10 bo poprzednio na Win 7 nie miałem tego a wszystko działało prawidłowo.
No cóż trzeba będzie trochę posiedzieć nad reinstalacją SW .
 
Zibi
2018-08-03, 06:49
Pomógł 0 raz(y).
Podłęcze się do tematu
Zainstalowałem właśnie w domu SW 2017 bo na takim pracujemy. Mam co prawda możliwość wyboru zapisu nagranego makra do formatów (*.csproj czy .vbproj) lecz próba zapisu kończy się takim komunikatem

następnie jeszcze jeden

nic oczywiście nie zapisuje

Przy instalacji zaznaczyłem VSTA nie wiem co jeszcze robię nie tak da się to jakoś rozwiązać ??
 
.
2018-08-03, 07:56
Pomógł 48 raz(y).
Mi instalował przez TeamViewera konsultant z Solideksperta bo samemu pomimo zaznaczenia tej opcji nie udało się. Strasznie coś mieszał i ustawiał, niestety nie zakodowałem wszystkiego co robił. Ale w końcu działa wszystko.
 
Zibi
2018-08-06, 06:08
Pomógł 0 raz(y).
No to ładne cacko jak bez piątego stopnia wtajemniczenia nie można poprawnie zainstalować i skonfigurować SOLIDWORKS nie bardzo wiem gdzie teraz uderzyć.
 
.
2018-08-06, 06:57
Pomógł 48 raz(y).
Jak dobrze pamiętam to opcji VSTA nie zaznaczał tylko coś innego ... porażka.
Jeśli masz licencję to zwróć się o pomoc do eksperta.
 

PSWUG

Strefa Resellera

Publikuj

Społeczność

Ankieta

Linki

RSS

BOT